In order for this site to work correctly we need to store a small file (called a cookie) on your computer. Most every site in the world does this, however since the 25th of May 2011, by law we have to get your permission first. Please abandon the forum if you disagree.

Para que este foro funcione correctamente es necesario guardar un pequeño fichero (llamado cookie) en su ordenador. La mayoría de los sitios de Internet lo hacen, no obstante desde el 25 de Marzo de 2011 y por ley, necesitamos de su permiso con antelación. Abandone este foro si no está conforme.

No lanza CreateObject()

Foro público de Xailer en español
Avatar de Usuario
XeviCOMAS
Mensajes: 587
Registrado: Sab Mar 12, 2011 8:16 pm

No lanza CreateObject()

Mensaje por XeviCOMAS »

Me encuentro con un problemilla...
Dado este código, que se lanza correctamente...

Código: Seleccionar todo

	WITH OBJECT CreateObject( "MSXML2.XMLHTTP.6.0" )
	:Open( "GET", "http://" +AppData:cXCM_DynDNS+ ":81/SMSMensario?" + cTextSend, .F. )
	:Send()

        LogDebug( :ResponseText )
   END
Este es un proceso que me devuelve el saldo de mensajes, en otro proceso casi igual, el cTextSend cambia poruq ele envio un mensaje. Pero al volver a solicitar el saldo, como esa petición ya la ha hecho una vez, no llega a hacer la solicitud.

Resulta que si el texto 'cTextSend' es el mismo a enviar, no llega a lanzarse el :Open().
Es como que lo ha hecho una vez, la segunda vez que lo lanzo, me devuelve el mismo resultado, cuando de evaluarse no devolvería el mismo.

¿Hay alguna manera de "forzar" a lanzar el :Open() caiga quien caiga... o 'limpiar' el buffer del objeto MSXML2.XMLHTTP.6.0 ???

Me trae de cabeza!!!


Gracias por vuestro tiempo.
Un Saludo,
Xevi.
Responder