In order for this site to work correctly we need to store a small file (called a cookie) on your computer. Most every site in the world does this, however since the 25th of May 2011, by law we have to get your permission first. Please abandon the forum if you disagree.

Para que este foro funcione correctamente es necesario guardar un pequeño fichero (llamado cookie) en su ordenador. La mayoría de los sitios de Internet lo hacen, no obstante desde el 25 de Marzo de 2011 y por ley, necesitamos de su permiso con antelación. Abandone este foro si no está conforme.

Problemas de visualización en el IDE

Foro público de Xailer en español
MarioG
Posts: 3
Joined: Sat Nov 30, 2019 8:30 pm

Problemas de visualización en el IDE

Postby MarioG » Fri Oct 23, 2020 4:17 pm

Buenos dias
Me pueden considerar como Nuevo, ya que el año pasado hice tibios intentos de arrancar.
Ahora mi deseo es tener continuidad sin cortes :-)
Estoy teniendo un problema menor y otro, que considero de importancia
El menor: A veces, cuando vuelvo de cerrar la aplicación la "cinta" de menú no se visualiza; lo que, por ahora, lo soluciono cerrando y reabriendo el IDE.
Ayer, conectado con Pedro, me comentó que están en conocimiento del problemas y que esperan solucionarlo con la próxima versión.
El problema serio: Se produce, tambien, al regresar de ejecutar la App. Al hacer clic en el icono Cambiar Módulo / Formulario... el formulario NO SE VISUALIZA!
Tampoco lo hace desde le Menu Ver... y para peor tampoco lo hace al cerrar y reabrir Xailer!
Esta es la segunda vez que me ocurre (o sea de la primera a esta rehice el proyecto)... mirando el lado bueno, no me viene mal porque practico :-)

Si alguien desea contactarme, por ayuda, en Skype me encuentran como MarioG
muchas gracias!
User avatar
ignacio
Site Admin
Posts: 8719
Joined: Mon Apr 06, 2015 8:00 pm
Location: Madrid, Spain
Contact:

Re: Problemas de visualización en el IDE

Postby ignacio » Sat Oct 24, 2020 11:48 am

Buenos días,

El menor: A veces, cuando vuelvo de cerrar la aplicación la "cinta" de menú no se visualiza;


Es la primera vez que oigo hablar de este problema. Supongo que se refiere a menú del IDE. Puede mandar una imagen? Gracias

El problema serio: Se produce, tambien, al regresar de ejecutar la App. Al hacer clic en el icono Cambiar Módulo / Formulario... el formulario NO SE VISUALIZA!


Debe de estar CARGADO y ACTIVO el PRG del formulario en el editor de código. Tampoco tenemos ninguna notificación de este error. Lo siento.

Un saludo
Ignacio Ortiz de Zúñiga
[Equipo de Xailer / Xailer team]
http://www.xailer.com
Ariel
Posts: 19
Joined: Tue Nov 26, 2019 12:28 pm

Re: Problemas de visualización en el IDE

Postby Ariel » Mon Oct 26, 2020 12:52 am

Ignacio,

el primer punto que plantea Mario, tambien me ocurre a veces, "desaparece" la barra de iconos de xailer, quedando a veces visibles el inspector de objetos y el inspector de prgs, pero desaparece, literalmente la cabecera, y como dice Mario se soluciona cerrando el IDE y volviendo a entrar.
Tengo w10 y 12Gb RAM

Saludos.
User avatar
ignacio
Site Admin
Posts: 8719
Joined: Mon Apr 06, 2015 8:00 pm
Location: Madrid, Spain
Contact:

Re: Problemas de visualización en el IDE

Postby ignacio » Mon Oct 26, 2020 11:56 am

Hola,

Cuando se produzca, agradezco una imagen. Gracias.

Un saludo
Ignacio Ortiz de Zúñiga
[Equipo de Xailer / Xailer team]
http://www.xailer.com
User avatar
MarceloAR
Posts: 19
Joined: Sun Dec 01, 2019 2:38 pm
Location: Argentina
Contact:

Re: Problemas de visualización en el IDE

Postby MarceloAR » Mon Oct 26, 2020 3:47 pm

Hola buenos dias/tardes, siguiendo el hilo justo este finde semana estuve viendo el ejemplo de xailer para el envío de email con CDO.
Tiene un formulario llamado Form1.prg - Form1.xfm y tampoco puedo ver el formulario.
Adjunto imagen
Image
Al pulsar F12 o el botón para ver el formulario no muestra nada
Espero que sirva lo expuesto
Saludos
Marcelo
Marcelo Roggeri
Argentina
User avatar
ignacio
Site Admin
Posts: 8719
Joined: Mon Apr 06, 2015 8:00 pm
Location: Madrid, Spain
Contact:

Re: Problemas de visualización en el IDE

Postby ignacio » Mon Oct 26, 2020 5:36 pm

Hola,

Supongo que el formulario debe estar tapado por el editor de código o alguna otra ventana. No sé me ocurre otra explicación. Pero se mostraría al pulsar dos veces a F12 o dos veces al botón equivalente. También es posible que lo hayan minimizado sin querer:
Imagen 099.png
Imagen 099.png (2.55 KiB) Viewed 19067 times

Espero que puedan reproducirlo con cualquier ejemplo de Xailer. Sin ello, es imposible hacer nada. Lo siento.

Un saludo
Ignacio Ortiz de Zúñiga
[Equipo de Xailer / Xailer team]
http://www.xailer.com
ddupre
Posts: 309
Joined: Mon Nov 12, 2007 3:53 pm

Re: Problemas de visualización en el IDE

Postby ddupre » Mon Oct 26, 2020 8:26 pm

Hola,
A mí en alguna oportunidad me sucede algo parecido con los form, dejo de verlos, en general es porque sin querer cambie las propiedades de ubicación o porque lo arrastré para algún lado, para poder ver otra cosa.
Yo trabajo con dos monitores y a veces más de un xailer abierto, lo resuelvo yendo al las propiedades del form que no "veo" (apretando F12) y le pongo provisoriamente lCentered en .T.
Espero que les sirva.
Saludos
Daniel
User avatar
MarceloAR
Posts: 19
Joined: Sun Dec 01, 2019 2:38 pm
Location: Argentina
Contact:

Re: Problemas de visualización en el IDE

Postby MarceloAR » Mon Oct 26, 2020 9:38 pm

Hola Daniel, yo también uso dos monitor, uso la tecla de función F12, revise eso de que este centrado en .T. y sigue sin aparecer.
Fijate el ejemplo de que esta en c:\xailer\samples\EnvioEmail, para ver si te pasa lo mismo.
Muchas gracias por tomarte la molestia de ayudarnos en esto que parece una tontera.
Saludos
Marcelo
Marcelo Roggeri
Argentina
Ariel
Posts: 19
Joined: Tue Nov 26, 2019 12:28 pm

Re: Problemas de visualización en el IDE

Postby Ariel » Mon Oct 26, 2020 11:02 pm

Solucionado,

el formulario principal tiene nLeft:= -700, cambiar a 0 o mayor y se visualiza correctamente.

Saludos
User avatar
jfgimenez
Site Admin
Posts: 5638
Joined: Mon Apr 06, 2015 8:48 pm
Contact:

Re: Problemas de visualización en el IDE

Postby jfgimenez » Fri Oct 30, 2020 9:37 am

Ariel,

el IDE calcula siempre las coordenadas de los formularios con respecto al monitor donde tengas el inspector de objetos. Parece que guardaste el formulario cuando tenías el inspector de objetos en el monitor de la derecha mientras que el formulario estaba en el monitor de la izquierda. Posteriormente has intentado abrirlo cuando el inspector de objetos estaba en el monitor de la izquierda. No se me ocurre ninguna otra explicación.

Mi consejo es que el formulario sobre el que estés trabajando esté siempre en el mismo monitor que el inspector de objetos.
José F. Giménez
[Equipo de Xailer / Xailer team]
http://www.xailer.com
http://www.xailer.info
MarioG
Posts: 3
Joined: Sat Nov 30, 2019 8:30 pm

Re: Problemas de visualización en el IDE

Postby MarioG » Fri Oct 30, 2020 11:16 am

Hola
Muchas gracias por las respuestas y consejos
Aunque, debo aclarar que no modifiqué la visualización del IDE. El inspector de Objetos lo tengo a la derecha y en consecuencia
Pero quizas, hice algo indebido; todo atribuido a mi etapa de aprendizaje.
Lo bueno fue que Ariel, ya había pasado por esta situación y me ayudo a solucionarlo.

Saludos!!
Ariel
Posts: 19
Joined: Tue Nov 26, 2019 12:28 pm

Re: Problemas de visualización en el IDE

Postby Ariel » Tue Nov 24, 2020 2:25 am

Jose,
solo tengo 1 monitor, uso una notebook, y "jamas" movi el form fuera de pantalla, pero bueno estare al pendiente si vuelve a pasar.
Saludos.

Return to “Spanish”